Allotment Gardening Advice Help Chat

Chatting => Equipment Shed => Topic started by: ryrys on May 03, 2012, 13:59

Title: I need some help please people with a briggs and stratton engine
Post by: ryrys on May 03, 2012, 13:59
Hello people my mower starts after priming but then just cuts out. I have cleaned the carb. changed the fuel and the spark plug and there are no apparent obvious problems.Any suggestions. Fanks. Ryrys
Title: Re: I need some help please people with a briggs and stratton engine
Post by: Dopey113 on May 03, 2012, 14:40
Air filter dirty? plugs have correct gap? is there an oil sensor on it?
Title: Re: I need some help please people with a briggs and stratton engine
Post by: smud6ie on May 03, 2012, 15:15
Hello people my mower starts after priming but then just cuts out. I have cleaned the carb. changed the fuel and the spark plug and there are no apparent obvious problems.Any suggestions. Fanks. Ryrys
More info needed please.make of mower,type of carb or numbers off engine would be good ,otherwise we fill the forum with  info which may not be specific to you machine.
smud6ie
Title: Re: I need some help please people with a briggs and stratton engine
Post by: Aunty on May 03, 2012, 15:40
Have you looked at this topic ?

http://chat.allotment-garden.org/index.php?topic=3345.0
Title: Re: I need some help please people with a briggs and stratton engine
Post by: Gwiz on May 03, 2012, 17:29
A little more information on the engine, or a photo would help.
If you have one of the "push to prime" bulbs on the engine, and the machine isn't very old, I'd expect that you may need to replace the carb diaphragm as they do wear out.
When you say you have cleaned the carb, did you strip it of the fuel tank (assuming it's one of the above mentioned carbs) and clean out the fuel pick up pipe? It has a very fine gauze on the end and is susceptible to blocking up.